飛狐FOX組合主圖指標公式

2011-01-26 11:10:00來源:本站整理瀏覽:1028

DRAWGBK(CLOSE>REF(MA(CLOSE,3),3),COLORRGB(85,0,113) ,COLORRGB(0,0,0),1);
DRAWGBK(CROSS(CLOSE,REF(MA(CLOSE,3),3)),COLORRGB(0,50,155) ,COLORRGB(0,0,30),1);
DRAWGBK(CROSS(REF(MA(CLOSE,3),3),CLOSE),COLORRGB(90,30,55) ,COLORRGB(0,50,00),1);
DRAWGBK(CLOSE<REF(MA(CLOSE,3),3),COLORRGB(50,110,0) ,COLORRGB(0,0,1),1);
{zmacd}
zqmacd:=DATATYPE;
rmacd:=OPENMINUTES(TIME);
zsmacd:=REF(CLOSE,rmacd);
zsrmacd:=DYNAINFO( 3);
jmacd:=SUM(CLOSE*VOL,SUMBARS(VOL,CAPITAL))/SUM(VOL,SUMBARS(VOL,CAPITAL));
jjmacd:=SUM(CLOSE*VOL,0)/SUM(VOL,0);
jjmacd1:=SUM(CLOSE*VOL,rmacd)/SUM(VOL,rmacd)LINETHICK0;
jjamacd:=IF(zqmacd=6,jjmacd,IF(zqmacd=1,jjmacd1,jjmacd));
zsamacd:=IF(zqmacd=6,zsrmacd,IF(zqmacd=1,zsmacd,zsrmacd));
crmacd:=IF(zqmacd=6,CLOSE>0,IF(zqmacd=1,rmacd>1,CLOSE>0));
PARTLINE(crmacd,zsamacd),COLORGRAY,POINTDOT;
dkmacd:=(SMA(CLOSE,2,1)-SMA(CLOSE,6,1))*2.1,LINETHICK0;
FILLRGN(dkmacd>0 and jjamacd>0 ,zsamacd,ZSamacd+dkmacd),Colorb3336633;
FILLRGN(dkmacd>0 and jjamacd>0 ,zsamacd,ZSamacd+dkmacd*0.97),COLORADBA9C;
FILLRGN(dkmacd>0 and jjamacd>0 ,zsamacd,ZSamacd+dkmacd*0.86),COLOR9CAA8C;
FILLRGN(dkmacd>0 and jjamacd>0 ,zsamacd,ZSamacd+dkmacd*0.75),COLOR8C9A73;
FILLRGN(dkmacd>0 and jjamacd>0 ,zsamacd,ZSamacd+dkmacd*0.66),COLOR738A63;
FILLRGN(dkmacd>0 and jjamacd>0 ,zsamacd,ZSamacd+dkmacd*0.55),COLOR637552;
FILLRGN(dkmacd>0 and jjamacd>0 ,zsamacd,ZSamacd+dkmacd*0.45),COLOR526542;
FILLRGN(dkmacd>0 and jjamacd>0 ,zsamacd,ZSamacd+dkmacd*0.4),COLOR425531;
FILLRGN(dkmacd>0 and jjamacd>0 ,zsamacd,ZSamacd+dkmacd*0.33),COLOR314521;
FILLRGN(dkmacd>0 and jjamacd>0 ,zsamacd,ZSamacd+dkmacd*0.25),COLOR213010;
FILLRGN(dkmacd>0 and jjamacd>0 ,zsamacd,ZSamacd+dkmacd*0.14),COLOR102000;
FILLRGN(dkmacd<=0 and jjamacd>0 ,zsamacd,ZSamacd+dkmacd),,Colorb3336633;
{說明}
DRAWTEXTEX(CLOSE,1,180,160,' 紅色初,股價靠近虛線入'),colorYellow;
DRAWTEXTEX(CLOSE,1,180,195,' 綠頭來,股價靠近虛線去'),colorYellow;
DRAWTEXTEX(CLOSE,1,180,225,' 金線上得金,銀線上的銀'),colorYellow;
DRAWTEXTEX(CLOSE,1,180,255,' 大盤個股趨向末明別性情'),colorYellow;
{vol}
r0:=0.96;
r:=(LOW-r0*SYSPARAM(5))/VOL;
r1:=LLV(r,SYSPARAM(3)-SYSPARAM(2));
r2:=r1[DATACOUNT];
r3:=LLV(LOW-r2*VOL,SYSPARAM(3)-SYSPARAM(2));
r4:=r3[SYSPARAM(3)];
r5:=(r2*VOL+r4)*0.995;
STICKLINE(CLOSE>=REF(CLOSE,1),r5,r0*SYSPARAM(5),7,1),color224455;
STICKLINE(CLOSE<REF(CLOSE,1),r5,r0*SYSPARAM(5),7,1),color553322;
八日量:MA(r5,8),SHIFT0,color606066;
十三日量:MA(r5,13),SHIFT0,color172271;
三日量:MA(r5,3),SHIFT0,color88ae00;
PARTLINE(三日量>=REF(三日量,1),三日量),Color88aedd,linethick1;
{MA}
Var1:=(HIGH+LOW+OPEN+CLOSE)/4;
A線:MA(3*Var1-2*SMA(Var1,2,1),12),COLORGREEN,LINETHICK1;
B線:=EMA(MA(CLOSE,13),2);
C線:EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55)*0.985,linethick1,colorgray;
FILLRGN(A線>C線,A線,C線),COLOR323167,LINETHICK1;
FILLRGN(A線>B線,B線,A線),COLOR323199,LINETHICK1;
FILLRGN(A線<=B線*1.0062,A線,C線),COLOR223311,LINETHICK1;
D線:B線,linethick1,LINEDOT,colorEEFF33;
MA55:MA(CLOSE,55),COLORFFCC66;
MA99:(MA(CLOSE,99)),CIRCLEDOT,Color006f05;
PARTLINE(A線>C線,C線),LINETHICK1,Color002288;
PARTLINE(A線<C線,C線),LINETHICK1,Color11412E;
PARTLINE(A線>B線,A線),LINETHICK1,Color002288;
PARTLINE(A線<B線,A線),LINETHICK1,Color11412E;
PARTLINE(MA99>REF(MA99,1),MA99),LINETHICK2,color888888;
PARTLINE(MA99>REF(MA99,1),MA99),LINETHICK1,colorffffff;
PARTLINE(MA99<REF(MA99,1),MA99),LINETHICK1,Color77462E;
MA55,LINETHICK2,colorFF;
MA55V:MA55,colorFFFF;
PARTLINE(MA55<REF(MA55,1),MA55),Color33EE00,linethick2;
PARTLINE(MA55<REF(MA55,1),MA55),Colorblue,linethick1;
{陰柱}
STICKLINE(OPEN>=CLOSE ,HIGH ,LOW,2,0 ),COLORGREEN;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
{粉柱}
STICKLINE(CLOSE>OPEN,HIGH,LOW,2,0) ,COLORRED;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLORFF00FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLORFF22FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLORFF44FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLORFF88FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFFAAFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLORFFBBFF;
{直板K}
STICKLINE(HIGH=LOW and CLOSE=OPEN and (CLOSE/REF(CLOSE,1))>1.048,HIGH,LOW,8,0) ,COLORRED;
STICKLINE(HIGH=LOW and CLOSE=OPEN and (REF(CLOSE,1)/CLOSE)>1.048,HIGH,LOW,8,0) ,COLOR00FF00;
S:=('股票代碼:' + STKLABEL);
DRAWTEXT((SYSPARAM(2) = BARPOS),CLOSE,S),ALIGN4,colorCCFFFF;
DRAWTEXT((BARPOS = SYSPARAM(2)),HIGH,((((((((((((((((((((((((((((((((((' 所屬板塊:' + BLKNAME) + '\n') + '發行價') +
NUMTOSTR(FINANCE(51),2)) + '元') + ' 發行量') + NUMTOSTR(FINANCE(52),2)) + '萬股') + '\n') + '總股本') + NUMTOSTR(FINANCE(1),0)) + '萬股')
+ ' 流通A股') + NUMTOSTR(FINANCE(7),0)) + '萬股') + ' 凈資產') + NUMTOSTR(FINANCE(35),2)) + '億元') + '
每股收益') + NUMTOSTR(FINANCE(33),2)) + '元') + ' 每股未分配') + NUMTOSTR(FINANCE(32),2)) + '元') + '\n') +
'市盈率') + NUMTOSTR(DYNAINFO(39),2)) + '%') + ' 投資收益') + NUMTOSTR(FINANCE(24),2)) + '元') + ' 股東總數')
+ NUMTOSTR(FINANCE(50),0)) + '戶')),ALIGN4,colorFF00;


 


炒股知識欄目導航

本類熱門

相關文章

初高中全集在线视频_9久9久女女热精品视频免费观看_人人澡人一摸人人添_yy6080理论亚洲一级理论人