通達信均線扭曲主圖指標公式

2013-08-03 09:04:00來源:本站整理瀏覽:1376

均價:=(C+(H+L)/2*0.382+(C+O)/2*0.618)/2;
X1:=EMA((均價+H)/2,5),COLORWHITE;
X2:=EMA(X1,8),COLORWHITE,LINETHICK2;
X3:=EMA(X2,13),COLORFFF000;
X4:=EMA(X3,21),COLORFFF000,LINETHICK2;
X5:=EMA(X4,34),COLORYELLOW;
X6:=EMA(X5,55),COLORYELLOW,LINETHICK2;
X7:=EMA(X6,89),COLOR7F00FF,LINETHICK2;
多空線:(X3+X4)/2,COLORMAGENTA;
反多空線:=EMA(多空線-(EMA(均價,2)-多空線),2),COLORGRAY,LINETHICK1;
{FILLRGN(反多空線>多空線,多空線,反多空線),COLORBLUE;
FILLRGN(反多空線<=多空線,多空線,反多空線),COLOR7F00FF,COLORBROWN;}
DRAWBAND(多空線,RGB(100,15,55),反多空線,RGB(0,100,150));
操盤線:X1,COLORWHITE;
盈虧線:X2,COLORLIGREEN,LINETHICK2;
啟動線:X3,COLORLIRED;
生命線:X4,COLORFFF000,LINETHICK2;
行情線:X6,COLORYELLOW,LINETHICK2;
牛熊線:X7,COLOR7F00FF,LINETHICK2;
乾坤線:=EMA(X6-(EMA((均價+C)/2,2)-X6),2);
IF(乾坤線>X6,X6,DRAWNULL),COLOR00AA99,LINETHICK2;
STICKLINE(OPEN>=CLOSE,HIGH,LOW,0,0),COLORFFCC00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF9F68;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.8,0),COLORFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.6,0),COLORFFAA11;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.5,0),COLORFFBB11;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.4,0),COLORFFCC22;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.3,0),COLORFFDD22;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2,0),COLORFFEE33;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1,0),COLORFFFF33;
STICKLINE(CLOSE>OPEN,HIGH,LOW,0,0),COLORFFFFFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLORCCFFFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.7,0),COLOR3300CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.6,0),COLOR33CCFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.5,0),COLOR6633CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.4,0),COLOR3333FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.3,0),COLOR6633FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0),COLOR3366FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0),COLOR6666FF;
{K線賣提示}
QC0:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
STICKLINE(QC0>=91 AND (CLOSE-LLV(CLOSE,5))/(HHV(CLOSE,5)-LLV(CLOSE,5))*100>99.9,OPEN,CLOSE,3,0),COLOR3366FF;
STICKLINE(QC0>=91 AND (CLOSE-LLV(CLOSE,5))/(HHV(CLOSE,5)-LLV(CLOSE,5))*100>99.9,H,L,0,0),COLOR3366FF;
{VAR11:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);{ZIG 有未來
VAR123:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2);}
KSD:=IF(O>C,O,C);
VAR12:=IF(TROUGHBARS(KSD,10,1)=1,1,0);
VAR1:=IF(PEAKBARS(KSD,10,1)=1,1,0);
STICKLINE(VAR1,C,O,3,0),COLORYELLOW,LINETHICK2;{高位黃色}
STICKLINE(VAR1,C,O,2,0),COLORGRAY,LINETHICK2;{高位黃色}
STICKLINE(VAR1,H,L,0.5,0),COLORYELLOW,LINETHICK2;{高位黃色}
STICKLINE(VAR12,C,O,3,0),COLOR9900FF,LINETHICK2;{底位紅色}
STICKLINE(VAR12,C,O,2,0),COLORWHITE,LINETHICK2;{底位紅色}
STICKLINE(VAR12,H,L,0.5,0),COLORMAGENTA,LINETHICK2;{底位紅色}
缺口:=(L>REF(H,1));
不破:=(EVERY(L>REF(H,BARSLAST(缺口)+1),BARSLAST(缺口)+1));
STICKLINE(不破,REF(H,BARSLAST(缺口)+1),REF(L,BARSLAST(缺口)),1,0),COLORYELLOW;
下缺口:=(H<REF(L,1));
不補:=(EVERY(H<REF(L,BARSLAST(下缺口)+1),BARSLAST(下缺口)+1));
STICKLINE(不補,REF(L,BARSLAST(下缺口)+1),REF(H,BARSLAST(下缺口)),1,0),COLORGREEN;
M1:=MA(C,5);
M2:=MA(C,18);
M3:=MA(C,34);
一陽1:=O<M1 AND C>M1;
一陽2:=O<M2 AND C>M2;
一陽3:=O<M3 AND C>M3;
一陽穿三線:=一陽1+一陽2+一陽3>2;
DRAWTEXT(一陽穿三線,L,'一陽三線');


 


 

股票公式欄目導航

本類熱門

相關公式

初高中全集在线视频_9久9久女女热精品视频免费观看_人人澡人一摸人人添_yy6080理论亚洲一级理论人