通達信鴻福黑馬主圖指標公式

2013-08-06 08:59:00來源:本站整理瀏覽:17912

N:=5;
N2:=13;
M1:=11;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
AA10:MA(CLOSE,8),COLOR0000FF;
AA12:MA(CLOSE,12),COLOR0000FF;
BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);
BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);
VAR1:=(C+H+O+L)/4;
賣出Q:=XMA(VAR1,20)*(1+80/1000),POINTDOT,COLORGREEN,LINETHICK3;
買入Q:=XMA(VAR1,32)*(1-100/1000),POINTDOT,COLORMAGENTA,LINETHICK3;
幅度:=100*(賣出Q-買入Q)/買入Q,NODRAW;
菩提:買入Q+(賣出Q-買入Q)*2/3;{此函數僅做參考線,為提前趨勢預測線,上漲途中向下見頂,下跌途中向上見底};
菩:HHV(菩提,2);
提:菩提-(菩-菩提);
般:=XMA(CLOSE,7);
若:=MEMA(CLOSE,3);
全綠K:LONGCROSS(若,般,3) AND H>菩提;
MA13:=MA(CLOSE,13);
趨勢:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42),POINTDOT,COLORFF00FF,LINETHICK4;
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000077;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR0000AA;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORAAAAAA;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
X1:=(C+L+H)/3;BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠45上升'),COLORWHITE;
壓力:MA(REF(HHV(C,30),1),2),COLOR00FF00;
支撐:MA(REF(LLV(C,30),1),2),COLOR0000FF;
AA1:=AMOUNT/V;BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;DD1:=L<MA(C,5)*0.921;EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;DRAWTEXT(FF1,(LOW* 0.99),'鼠'),COLOR4080FF;
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑馬線:=EMA(A51,5);A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趨勢線:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
DRAWTEXT(CROSS(趨勢線,0)AND 黑馬線<40,(HIGH* 0.97),'▲黑馬'),COLORYELLOW;
FF:=EMA(CLOSE,3);MA15:=EMA(CLOSE,21);
{DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背'),COLORFF00FF;}
STICKLINE(CROSS(FF,MA15),O,C,0.3,0),COLOR00FFFF;
{DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'頂背'),COLOR00FF00;}
STICKLINE(CROSS(88,RSI),O,C,0.3,0),COLOR113311;
VAR2:=LLV(LOW,27);VAR3:=HHV(HIGH,34);VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*25;
注意買:=IF((VAR4<10),80,100);RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;超跌:=IF(J<0,10,0);BDDD:=LLV(J,2)=LLV(J,8);
買入:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20,30,0);
DRAWTEXT(買入 AND 注意買=100 AND 超跌=0,LOW,'B'),COLOR8000FF;
MTM:=C-REF(C,1);DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
買:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(買=1,5),LOW-0.03,'拉'),COLOR0000FF;
GET:ZIG(3,N),COLORYELLOW;
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走強1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走強2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走強3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走強2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走強2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走強3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走強3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.95,'(A)'),COLORFFFF00;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'(B)'),COLORFF00FF;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.95,'(C)'),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'⑴'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'⑵'),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'⑶'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'⑷'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'⑸'),COLOR0000FF;
DRAWTEXT(EN2 AND DTJZ10=1,L*0.93,'Ⅰ'),COLORFF00FF;
DRAWTEXT(EX2 AND DTJD10=2,H*1.01,'Ⅱ'),COLORFFFF00;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.93,'Ⅲ'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.06,'①'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.94,'②'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.06,'③'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.94,'④'),LINETHICK3,COLOR00FFFF;
V1:=EMA(CLOSE,60)-EMA(CLOSE,453);
V2:=EMA(V1,453);
V3:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
V4:=SMA(V3,2,1);
V5:=SMA(V4,2,1);
V6:=CLOSE/REF(CLOSE,3)>=1.05 ;
V7:=BACKSET(V6,3);
大漲買:=(V7 AND COUNT(V7,5)=1);
STICKLINE(大漲買,O,((C+O)/2),8,0),COLORYELLOW,LINETHICK2;{底位黃色}
STICKLINE(大漲買,O,((C+O)/2),4,0),COLORRED,LINETHICK2;{底位黃色}
STICKLINE(大漲買,O,((C+O)/2),2,0),COLORGREEN,LINETHICK2;{底位黃色}
DRAWTEXT(大漲買,LOW*0.98,'爆'),COLOR88FF22;
QA3:=REF(H,N2)=HHV(H,2*N2+1);
QB3:=FILTER(QA3,N2);
QC3:=BACKSET(QB3,N2+1);
QD3:=FILTER(QC3,N2);{高點}
QA4:=REF(L,N2)=LLV(L,2*N2+1);
QB4:=FILTER(QA4,N2);
QC4:=BACKSET(QB4,N2+1);
QD4:=FILTER(QC4,N2);{低點}
VR1:=(HIGH+LOW+CLOSE)/3;
VR2:=(VR1-MA(VR1,14))/(0.015*AVEDEV(VR1,14));
VR3:=(VR1-MA(VR1,70))/(0.015*AVEDEV(VR1,70));
VR4:=IF(VR2>=150 AND VR2<200 AND VR3>=150 AND VR3<200,100,IF(VR2<=-150 AND VR2>-200 AND VR3<=-150 AND VR3>-200,-100,0));
VR5:=IF(VR2>=150 AND VR2<200 AND VR3>=150 AND VR3<200,100,0);
VR6:=IF(VR2<=-150 AND VR2>-200 AND VR3<=-150 AND VR3>-200,-100,0);
VR7:=IF(VR2>=200,200,IF(VR2<=-200,-200,VR4));
頂:= (0-IF(VR3>=200,200,VR5)+400);
底:=(0-IF(VR3>=200,0,IF(VR3<=-200,-200,VR6))-400);
測底:=-200;
測頂:=200;
買股:=(QD4 OR (QD4 AND C>O AND VOL>REF(LLV(VOL,60),1)))*15.21875>2;
持幣:=(QD3 OR (QD3 AND C<O AND VOL>MA(VOL,5) AND VOL>MA(VOL,60)))*15.21875>2;
DRAWTEXT(QD3 OR (QD3 AND C<O AND VOL>MA(VOL,5) AND VOL>MA(VOL,60)),H*1.02,'持幣!'),COLORWHITE;
AD:=(買股 AND 測底);
DRAWTEXT(AD,L,'買股!'),COLORWHITE;
STICKLINE(持幣,O,(O+C)/2,4,0),COLORBLUE;
STICKLINE(持幣,O,(O+C)/2,2,0),COLORWHITE;
RVAR6:=EMA(HHV(HIGH,500),21);
RVAR7:=EMA(HHV(HIGH,250),21);
RVAR8:=EMA(HHV(HIGH,90),21);
RVAR9:=EMA(LLV(LOW,500),21);
RVARA:=EMA(LLV(LOW,250),21);
RVARB:=EMA(LLV(LOW,90),21);
RVARC:=EMA((RVAR9*0.96+RVARA*0.96+RVARB*0.96+RVAR6*0.558+RVAR7*0.558+RVAR8*0.558)/6,21);
RVARD:=EMA((RVAR9*1.25+RVARA*1.23+RVARB*1.2+RVAR6*0.55+RVAR7*0.55+RVAR8*0.65)/6,21);
RVARE:=EMA((RVAR9*1.3+RVARA*1.3+RVARB*1.3+RVAR6*0.68+RVAR7*0.68+RVAR8*0.68)/6,21);
RVARF:=EMA((RVARC*3+RVARD*2+RVARE)/6*1.738,21);
RVAR10:=REF(LOW,1);
RVAR11:=SMA(ABS(LOW-RVAR10),3,1)/SMA(MAX(LOW-RVAR10,0),3,1)*100;
RVAR12:=EMA(IF(CLOSE*1.35<=RVARF,RVAR11*10,RVAR11/10),3);
RVAR13:=LLV(LOW,30);
RVAR14:=HHV(RVAR12,30);
RVAR15:=IF(MA(CLOSE,58),1,0);
RVAR16:=EMA(IF(LOW<=RVAR13,(RVAR12+RVAR14*2)/2,0),3)/618*RVAR15;
RVAR17:=IF(RVAR16>50,50,RVAR16)/3.82*6;
RVAR18:=RVAR17>0 AND AD;
吸籌:STICKLINE(RVAR18,C,(C+O)/2,8,1),COLORGREEN ;
STICKLINE(RVAR18,C,(C+O)/2,2,1),COLORRED;
DRAWTEXT(RVAR18,L*0.96,'加重籌碼'),COLORYELLOW;
{全綠K}
全綠K2:=C>賣出Q OR (H>賣出Q AND O>C);
STICKLINE(全綠K2,C,O,3,0),COLOR00BB00;
STICKLINE(全綠K2,C,O,2,0),COLOR00DD00;
STICKLINE(全綠K2,C,O,1,0),COLOR00FF00;
STICKLINE(全綠K,O,C,2,1),COLORBLUE;
AS:=PEAKBARS(3,M1,3)*1.1521875;
派AH:=CROSS(AS,REF(AS,1));
STICKLINE(派AH,O,(C+O)/2,5,0),COLORWHITE;
STICKLINE(派AH,O,(C+O)/2,1,0),COLORBLUE;
DRAWTEXT(派AH,H*1.01,'籌碼松動'),COLORCYAN;
DRAWTEXT_FIX(1,0.00,0,0,'所屬行業:')COLOR0080FF;
DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0,0.10,0,STRCAT('千股千評: ',EXTERNSTR(0,1))),COLORYELLOW;
DRAWTEXT_FIX(1,0.00,0.18,0,'愚民主題概念:')COLORLIGREEN;
DRAWTEXT_FIX(1,0.07,0.18,0,EXTERNSTR(0,2))COLORLIGREEN;
DRAWTEXT_FIX(1,0.00,0.26,0,'行業龍頭:')COLORFF88FF;
DRAWTEXT_FIX(1,0.07,0.26,0,EXTERNSTR(0,3))COLORFF88FF; {生成數據時第1項輸3與這里3一致,描述部分輸"出千概念"};
DRAWTEXT_FIX(1,0.00,0.34,0,'主題投資:')COLORLIBLUE;
DRAWTEXT_FIX(1,0.07,0.34,0,EXTERNSTR(0,10))COLORLIBLUE;
DRAWTEXT_FIX(1,0.00,0.42,0,'主力成本:')COLORLIRED;
DRAWTEXT_FIX(1,0.07,0.42,0,EXTERNSTR(0,9))COLORLIRED;
DRAWTEXT_FIX(1,0.00,0.50,0,'資金流向:')COLORYELLOW;
DRAWTEXT_FIX(1,0.07,0.50,0,EXTERNSTR(0,6))COLORYELLOW;
DRAWTEXT_FIX(1,0.00,0.58,0,'智能診斷:')COLORFF88FF;
DRAWTEXT_FIX(1,0.07,0.58,0,EXTERNSTR(0,12))COLORFF88FF;
DRAWTEXT_FIX(1,0.00,0.66,0,'業績預告:')COLORLIRED;
DRAWTEXT_FIX(1,0.07,0.66,0,EXTERNSTR(0,20))COLORLIRED;


 


股票公式欄目導航

本類熱門

相關公式

初高中全集在线视频_9久9久女女热精品视频免费观看_人人澡人一摸人人添_yy6080理论亚洲一级理论人