通達信主力大戶資金進出指標(源碼)

2014-01-29 19:54:00來源:本站整理瀏覽:16186

N:=34;
預測量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),COLORCCCCFF,NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,預測量,0,8,-1),COLORYELLOW;
【成交量】:VOL,VOLSTICK,COLORRED;
成交額億:=AMOUNT/100000000,NODRAW;
流通:=CAPITAL/1000000,NODRAW;
成交流通比:=AMOUNT/CAPITAL/100,NODRAW;
大盤成交【手】:INDEXV,COLORFF55FF,NODRAW;
漲家數:INDEXADV,COLOR0000EE,NODRAW;
跌家數:INDEXDEC,COLOR00EE00,NODRAW;
STICKLINE(CLOSE=REF(CLOSE,1),0,VOL,3.2,0),COLORFF77FF;
STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,2.7,0),COLORFF33FF;
STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,2.1,0),COLORFF55FF;
STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,1,6),COLORFF77FF;
STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,0.8,0),COLORFF99FF;
STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,0.5,0),COLORFFBBFF;
STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,0.1,0),COLORFFDDFF;
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,3,2),COLORFF1100;
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,2.7,0),COLORFF3300;
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,2.1,0),COLORFF5500;
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,1.6,0),COLORFF7700;
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,0,8),COLORFF9900;
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,0.5,0),COLORFFBB00;
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,0.1,0),COLORFFDD00;
HL10:=WINNER(C/1.1)*V,COLORBLUE;
{STICKLINE(((C/1.1)*V),HL10,0,3,0),COLORMAGENTA;}
STICKLINE(HL10>0,0,HL10,3,2),COLORFF0033;{紫羅蘭色--攻擊量}
STICKLINE(HL10>0,0,HL10,2.7,0),COLORFF0066;
STICKLINE(HL10>0,0,HL10,2,1),COLORFF0099;
STICKLINE(HL10>0,0,HL10,1.6,0),COLORFF00CC;
STICKLINE(HL10>0,0,HL10,0.5,0),COLORFF00FF;
HL20:=WINNER(C/1.2)*V;
{STICKLINE(((C/1.2)*V),HL20,0,2.1,0)COLORYELLOW;}
STICKLINE(HL20>0,0,HL20,3,2),COLOR0035FF; {黃色--潛入量}
STICKLINE(HL20>0,0,HL20,2.7,0),COLOR0064FF;
STICKLINE(HL20>0,0,HL20,2,1),COLOR0093FF;
STICKLINE(HL20>0,0,HL20,1.6,0),COLOR00C2FF;
STICKLINE(HL20>0,0,HL20,0.5,0),COLOR00FFFF;
HL30:=WINNER(C/1.3)*V;
STICKLINE(((C/1.3)*V),HL30,0,2.5,0),COLORRED;
STICKLINE(HL30>0,0,HL30,3.2,0),COLOR000066;{紅色--拉升量}
STICKLINE(HL30>0,0,HL30,2,7),COLOR000077;
STICKLINE(HL30>0,0,HL30,2.1,0),COLOR000099;
STICKLINE(HL30>0,0,HL30,1.6,0),COLOR0000CC;
STICKLINE(HL30>0,0,HL30,0.2,0),COLORCC66FF;
MA5:MA(V,5),COLORLIMAGENTA;
MA13:MA(V,13),COLORCYAN;
DRAWTEXT(CROSS(MA5,MA13),(V *1.05),'★'),COLORYELLOW;
{VOL動能均分量}
換手:=V*100/CAPITAL;
主力:=MA(換手,4);
大戶:=MA(換手,9);
中戶:=MA(換手,17);
散戶:=MA(換手,34);
均量:=(主力+大戶+中戶+散戶)/4;
主力能量:=(主力-均量);
大戶能量:=(大戶-均量);
中戶能量:=(中戶-均量);
散戶能量:=(散戶-均量);
DRAWTEXT(V>0 AND ISLASTBAR AND ABS(主力能量),V*0.98,IF(主力能量>0 AND 主力能量>REF(主力能量,1),' 機構+',' 機構-')),COLORYELLOW;
DRAWTEXT(V>0 AND ISLASTBAR AND ABS(大戶能量),V/4*3,IF(大戶能量>0 AND 大戶能量>REF(大戶能量,1),' 大戶+',' 大戶-')),COLOR0000CC;
DRAWTEXT(V>0 AND ISLASTBAR AND ABS(中戶能量),V/2,IF(中戶能量>0 AND 中戶能量>REF(中戶能量,1),' 中戶+',' 中戶-')),COLORMAGENTA;
DRAWTEXT(V>0 AND ISLASTBAR AND ABS(散戶能量),V/4,IF(散戶能量>0 AND 散戶能量>REF(散戶能量,1),' 散戶+',' 散戶-')),COLORCYAN;
{--------VOL.量能飽和--------}
N1:=N;
N2:=N1*1.05;
N3:=N1+3;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能飽和:IF(SAT>1,1,SAT)*100,COLORYELLOW,NODRAW;
中點:=REFDATE(HHV(V,100)/2,DATE);{量能飽和的變色切換}
{中點:=REFDATE(HHV(V,240)/2,DATE);}
STICKLINE(CURRBARSCOUNT=N1,中點*1.9,中點*1.5,100,1),COLOR00DDDD;
STICKLINE(CURRBARSCOUNT=N1,中點*1.88,中點*1.52,量能飽和,0),COLOR0033FF;
STICKLINE(CURRBARSCOUNT=N1,中點*1.82,中點*1.58,量能飽和,0),COLOR0077FF;
STICKLINE(CURRBARSCOUNT=N1,中點*1.76,中點*1.64,量能飽和,0),COLOR0099FF;

股票公式欄目導航

本類熱門

相關公式

初高中全集在线视频_9久9久女女热精品视频免费观看_人人澡人一摸人人添_yy6080理论亚洲一级理论人