通達信集合背離改良版指標(源碼)

2014-11-17 20:45:00來源:本站整理瀏覽:182

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;
STICKLINE(低位金叉,0,-0.18,1,0),COLORYELLOW;
DRAWTEXT(低位金叉,-0.15,' 低位金叉'),COLORRED;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,-0.18,1,0),COLORFF00FF;
DRAWTEXT(二次金叉,-0.3,' 二次金叉'),COLORFF00FF;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背離:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
STICKLINE(底背離,0,0.13,1,0),COLOR00FF00;
DRAWTEXT(底背離,0.18,' 底背離'),COLOR00FF00;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
頂背離:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背離,0.51,'三全項'),COLORYELLOW,LINETHICK2;
DRAWTEXT(低位金叉 AND 底背離,0.31,'兩全項'),COLORLIBLUE,LINETHICK2;
上翹:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
下拐:IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORLIBLUE,LINETHICK2;
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");
DRAWTEXT(B3>0,-0.3,'RSI底離'),COLORCYAN;{RSI底背離};
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
DRAWTEXT(D3>0,0.8,'RSI頂離'),COLORGREEN;{RSI頂背離};


股票公式欄目導航

本類熱門

相關公式

初高中全集在线视频_9久9久女女热精品视频免费观看_人人澡人一摸人人添_yy6080理论亚洲一级理论人