通達信經典分時主圖 源碼

2016-10-17 18:17:00來源:本站整理瀏覽:302

DRAWGBK(O>=0,RGB(60,35,0),RGB(0,60,60),0,'背景圖',0),LINETHICK2;
{========================額外==========================}
Z1:=STRCAT(DYBLOCK,' ');
Z2:=STRCAT(Z1,HYBLOCK);
Z3:=STRCAT(Z2,' ');
Z4:=STRCAT(Z3,GNBLOCK);
Z5:=STRCAT(Z4,' ');
Z6:=STRCAT(Z5,FGBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0.01,0.012,0,STRCAT(Z6,ZHBLOCK)),COLORCYAN;


DRAWTEXT_FIX(ISLASTBAR,0,0.14,0,STRCAT('概 念: ',GNBLOCK)),COLORWHITE;
A1:=(VOL/CLOSE)/3;
A2:=SUM((IF(((A1>40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);
A3:=SUM((IF(((A1>40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);
A4:=SUM((IF(((A1<40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);


突破:=REF(EMA(C,14),1);
A1X:=(EMA(C,10)-突破)/突破*100;
多方:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);
空方:=IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);
STICKLINE(A1X>=0,多方,突破,0,0),COLOR000099;
STICKLINE(A1X<0,空方,突破,0,0),COLOR00CC66;
最新:CLOSE,LINETHICK1,COLORWHITE;
AA:=SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C));
BB:=BETWEEN(C/AA,C+H,C-H);
DRAWTEXT( ISLASTBAR AND 最新>REF(最新,1),最新,STRCAT(' 漲▲',CON2STR(最新,2))),COLORMAGENTA;
DRAWTEXT( ISLASTBAR AND 最新<REF(最新,1),最新,STRCAT(' 跌▼',CON2STR(最新,2))),COLOR00FF00;
DRAWTEXT_FIX(1,0.880,1-0.97,0,DYBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.940,1-0.97,0,HYBLOCK),COLORYELLOW;
均價:SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK1;
DXJP:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,21)-LLV(LOW,34))*100;
FSZX:=(EMA(DXJP,3)-50)*2,COLORGRAY;
BGTYU:=IF(DATE<=1150530,1,0);
GHYJKU:=BETWEEN((DCLOSE*BGTYU)/(SUM(AMOUNT,BARSCOUNT((DCLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*BGTYU)))),1.05,0.95);
VBNH:=IF(GHYJKU=0,MA((DCLOSE*BGTYU),BARSCOUNT((DCLOSE*BGTYU))),(SUM(AMOUNT,BARSCOUNT((DCLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*BGTYU)))));
DRAWICON(FSZX<=-95,C,38);
DRAWTEXT(CROSS(EXPMA((DCLOSE/VBNH),20),1.04),C,'板'),COLORCYAN;
DRAWTEXT(CROSS(EXPMA((DCLOSE/VBNH),20),1.02),C,'追'),COLORYELLOW;

H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,COLORGREEN;
支撐:=L1+P1*0.5/8,COLORMAGENTA;
DRAWICON(LONGCROSS(支撐,C,2),C,5);


AYGB1:=(DVOL/C)/2,NODRAW;
AYGB2:=SUM(IF(AYGB1>100 AND CLOSE>REF(CLOSE,1),AYGB1,0),0);
AYGB3:=SUM(IF(AYGB1>100 AND CLOSE<REF(CLOSE,1),AYGB1,0),0);
AYGB4:=SUM(IF(AYGB1<100 AND CLOSE>REF(CLOSE,1),AYGB1,0),0);
AYGB5:=SUM(IF(AYGB1<100 AND CLOSE<REF(CLOSE,1),AYGB1,0),0);
AYGB6:=AYGB2+AYGB3+AYGB4+AYGB5;
機買:=(AYGB2/AYGB6)*100-100,LINETHICK1,COLORRED;
機賣:=(AYGB3/AYGB6)*100-100,LINETHICK1,COLORGREEN;
主力差:=機買-機賣;
LQH:=主力差>0 AND REF(主力差,1)<=0;
DRAWICON(LQH,C,25);
JJXX:=IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0))),COLORYELLOW;
JJXXH:=(JJXX*1.007 ),COLORFF6600;
FFLL:=SUM(VOL,6)>REF(MA(VOL,30),1)*10;
HHPP:=((HHV(CLOSE,BARSCOUNT(CLOSE))-LLV(CLOSE,BARSCOUNT(CLOSE)))/CLOSE)<1;
HHZZ:=HHPP AND FFLL AND (C>JJXXH);
TTPP2:=FILTER(HHZZ,100);
DRAWICON(TTPP2,C,26);
ZS:=DYNAINFO(3);
KP:=DYNAINFO(4);
ZX:=DYNAINFO(7);
ZG:=DYNAINFO(5);
ZD:=DYNAINFO(6);

分時均價線:SUM(C*V,240)/SUM(V,240),COLORYELLOW;


RC:=DYNAINFO( 3);
量比超2.5:=IF(DYNAINFO(17)>2.5,RC-0.15,DRAWNULL),COLORFF9933;
量比超5:=IF(DYNAINFO(17)>5,RC-0.15,DRAWNULL),COLORBA75FF;
DRAWBAND(量比超2.5,RGB(51,153,255),量比超2.5+0.015,RGB(51,153,255));
DRAWBAND(量比超5,RGB(255,118,188),量比超5+0.015,RGB(255,118,188));

{首次起爆}
TT:=BARSCOUNT(C);{取得有效收盤價}
均價黃:SUM(C*V,TT)/SUM(V,TT),LINETHICK1,COLOR00FFE1;{分時均線的取值}
量兩步:=MA(V,5)>REF(MA(V,5),1) AND REF(MA(V,5),1)>REF(MA(V,5),2);
價兩步:= C>=REF(C,1) AND REF(C,1)>REF(C,2);
價上崗量破5:=C>均價黃 AND V>MA(V,5);
量起爆:=V>=REF(V,1)*2 ;
價創新高:=C>=HHV(C,0);
量創新高:=V>=HHV(V,0);
對昨日漲幅:=C/DYNAINFO(3)<=1.02;{漲幅控制2個點以內}
每日一點:=量兩步 AND 價兩步 AND 價上崗量破5 AND 量起爆 AND 價創新高 AND 量創新高 AND 對昨日漲幅;
{計算收益、已爆分鐘}
VC:=BARSSINCE(每日一點)+1;
首次起爆價:REF(C,VC-1),NODRAW;
今天收益:(DYNAINFO(7)-首次起爆價)/首次起爆價*100,NODRAW;
起爆時間:REF(TIME/10000,VC),NODRAW;
已爆分鐘:VC-1,NODRAW;
首次起爆量:=REF(VOL,VC-1);
DRAWICON(已爆分鐘>=2,RC-0.1,11);{出現金手指,至少已經確認2分鐘了};

R1:=MA(C,13);
R2:=SMA(R1,5,2);
DRAWBAND(R1,RGB(255,0,125),R2,RGB(0,111,255));

C,LINETHICK2,COLORDDDDDD;

{漲停}
地:=DYNAINFO(11)+(DYNAINFO(11)*0.021);
漲停:IF(DYNAINFO(7)>地,1,0),NODRAW,COLOR0088FF;
漲:=IF(漲停=1,C+0.0075,DRAWNULL),COLOR8000FF,LINETHICK2;
DRAWBAND(漲,RGB(255,211,0),C-0.0075,RGB(255,125,0));

時間:=TIME=100000;
N:=BARSLAST(時間);
常數:=CONST(IF(N=0,C,REF(C,N))),COLORGREEN,DOTLINE;

[1] [2]  下一頁

股票公式欄目導航

本類熱門

相關公式

初高中全集在线视频_9久9久女女热精品视频免费观看_人人澡人一摸人人添_yy6080理论亚洲一级理论人