通達信集合了一些自認為可以參考的公式指標主圖源碼

2017-04-28 22:33:00來源:本站整理瀏覽:191

感覺還是有一些參考價值的一些東西


P:=8;
KE:=V*(H-L)/REF(C,1);
KEP:=KE=HHV(KE,P);
KUD:=BARSLAST(KEP);
{紅平臺收:IF(IF(KUD=0,C>REF(C,1),REF(C,KUD)>REF(REF(C,1),KUD)),IF(KUD=0,C,REF(C,KUD)),DRAWNULL),POINTDOT,COLORYELLOW;}
紅平臺低:IF(IF(KUD=0,C>REF(C,1),REF(C,KUD)>REF(REF(C,1),KUD)),IF(KUD=0,L,REF(L,KUD)),DRAWNULL),POINTDOT,COLORWHITE;

{STICKLINE(IF(KUD=0,C>REF(C,1),REF(C,KUD)>REF(REF(C,1),KUD)),紅平臺收,紅平臺收,6,1),COLORYELLOW;}
STICKLINE(IF(KUD=0,C>REF(C,1),REF(C,KUD)>REF(REF(C,1),KUD)),紅平臺低,紅平臺低,6,1),COLORWHITE;

Y:=(MA(C,5)-MA(C,30))/MA(C,5)*100;
YY1:=C>MA(C,5) AND OPEN<MA(C,5);{龍出海}
YY3:=C>MA(C,10) AND OPEN<MA(C,10);
YY5:=C>MA(C,30) AND OPEN<MA(C,30);
DRAWTEXT(YY1 AND YY5 AND YY3,LOW-0.2,'←龍出海'),COLORYELLOW;

獲利%:WINNER(CLOSE)*100,NODRAW,COLORWHITE;
DRAWTEXT_FIX(獲利%>=95 AND ISLASTBAR,0.97,0.97,0,'高危'),COLORRED;
DRAWTEXT_FIX(獲利%>=80 AND 獲利%<95 AND ISLASTBAR,0.97,0.97,0,'風險'),COLORYELLOW;
DRAWTEXT_FIX(獲利%>=50 AND 獲利%<80 AND ISLASTBAR,0.97,0.97,0,'安全'),COLORGREEN;
DRAWTEXT_FIX(獲利%<50 AND ISLASTBAR,0.97,0.97,0,'空頭'),COLORBLUE;
STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,3,0),COLOR0055FF;
STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,3,0),COLOR00FF00;
N:=10;
T1:=CONST(HHVBARS(V,N));
T0:IF(CURRBARSCOUNT<=N+3,CONST(IF(T1=0,C,REF(C,T1))),DRAWNULL),COLORFF00FF;
IF(CURRBARSCOUNT=T1+1,T0,DRAWNULL),CIRCLEDOT,COLORFF00FF;
DRAWTEXT(ISLASTBAR,T0,' 量能平臺'),COLORCC00CC;
M:=10;
Q1:=CONST(REF(HHVBARS(V,M),T1+1)+T1+1);
Q0:IF(CURRBARSCOUNT<=T1+M+3 AND CURRBARSCOUNT>=T1+1,CONST(REF(C,Q1)),DRAWNULL),COLOR009900;
IF(CURRBARSCOUNT=Q1+1,Q0,DRAWNULL),CIRCLEDOT,COLOR00CC00;
M1:=CONST(LLVBARS(V,M));
M0:IF(CURRBARSCOUNT<=M+7,CONST(IF(M1=0,O,REF(O,M1))),DRAWNULL);
IF(CURRBARSCOUNT=M1+1,M0,DRAWNULL),CIRCLEDOT;
DRAWTEXT(ISLASTBAR,M0,' 地量反量能平臺');

T11:=CONST(LLVBARS(LOW,10));
T11HIGH:=CONST(REF(HIGH,T11));
CC1:=CONST(CURRBARSCOUNT);
T22:=CONST(BARSLAST(CURRBARSCOUNT>CC1+T11 AND H>T11HIGH));
T22HIGH:=CONST(REF(HIGH,T22));
T33:=CONST(BARSLAST(CURRBARSCOUNT>CC1+T22 AND HIGH>T22HIGH));
T33HIGH:=CONST(REF(HIGH,T33));
C>=T33HIGH AND REF(C,1)<T33HIGH
AND DYNAINFO(17)>2;

NA:=10;
T1A:=CONST(LLVBARS(LOW,NA));
T1HIGH:=CONST(REF(HIGH,T1A));
CC:=CONST(CURRBARSCOUNT);
T2:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T1A)) AND (HIGH>T1HIGH)));
T2HIGH:=CONST(REF(HIGH,T2));
T3:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T2)) AND (HIGH>T2HIGH)));
T3HIGH:=CONST(REF(HIGH,T3));
洗盤殺入線:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),LINETHICK3,COLOR0000FF;
DRAWTEXT(ISLASTBAR, T3HIGH, ' 洗盤殺入線')LINETHICK1,COLORYELLOW;

通達信集合了一些自認為可以參考的公式指標主圖源碼

 


 

股票公式欄目導航

本類熱門

相關公式

初高中全集在线视频_9久9久女女热精品视频免费观看_人人澡人一摸人人添_yy6080理论亚洲一级理论人