優化后的超級MACD 通達信副圖指標 源碼 貼圖

2020-05-20 09:13:00來源:本站整理瀏覽:395

優化后的超級MACD 通達信副圖指標 源碼 貼圖

優化后的超級MACD 通達信副圖指標 源碼 貼圖


{MACD}
DIF:EMA(CLOSE,6)-EMA(CLOSE,19),,NODRAW;
DEA:EMA(DIF,9),NODRAW;
MACD:2*(DIF-DEA),COLORSTICK;
STICKLINE(MACD>0,MACD,0,0.5,0),COLORRED;
STICKLINE(MACD<0,MACD,0,0.5,0),COLORGREEN;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.5,0),COLORWHITE;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.5,0),COLORFF00FF;
FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;
FH5:=FH1 AND FH2 AND MACD<0.10;
VV:=CLOSE>OPEN AND MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,30)
AND DIF>DEA AND MACD>REF(MACD,1) AND DIF>0 AND DEA>0 AND
MA(VOL,5)>MA(VOL,34) AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1);
佛手:IF(VV,1,0),NODRAW;
{二次起動}
X0:=BARSLAST((CROSS(MACD,REF(MACD,1)) AND MACD>0) OR CROSS(MACD,0));
X1:=BARSLAST(CROSS(0.5,COUNT(MACD>REF(MACD,1),X0+1)=X0+1));{回}
X2:=COUNT(MACD<REF(MACD,1),X1+1)=X1+1 AND COUNT(MACD<0,X1+1)<=2;{www.gpxiazai.com}
X3:=REF(X2,1) AND MACD>REF(MACD,1) AND C>O AND C>REF(C,1);
STICKLINE(X1=0 AND MACD>0,MACD,0,2,0),COLORDCDC00;{MACD縮頭}
STICKLINE(X3,MACD,0,2,0),COLOR0854FF;{二次起動};
DRAWICON(佛手,-0.15,11);
二次翻紅:(FH3 OR FH4 OR FH5),COLORRED,NODRAW;
低買:CROSS(DIF,DEA) AND DIF<0,COLORFF00FF,NODRAW;
加油:CROSS(DIF,DEA) AND DIF>0,COLORYELLOW,NODRAW;
DRAWICON(二次翻紅,-0.05,1);
DRAWTEXT(二次翻紅,-0.15,'↖翻紅'),COLORRED;
DRAWTEXT(CROSS(DIF,DEA) AND DIF<0,DEA-0.02,'↖低買'),COLORFF00FF;
DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,DEA-0.05,'↖加油'),COLORYELLOW;
XG:二次翻紅 OR 低買 OR 加油,NODRAW;
YLZC:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);
阻價:=IF(CLOSE=INDEXC,YLZC+INDEXC-INDEXL,YLZC+(CLOSE-LOW));
支價:=IF(CLOSE=INDEXC,INDEXL+INDEXC-YLZC,LOW+(CLOSE-YLZC));
今壓:REF(阻價,1),LINETHICK0,COLORAA11BB,NODRAW;
今撐:REF(支價,1),LINETHICK0,COLOR009900,NODRAW;
明壓:阻價,LINETHICK0,NODRAW;
明撐:支價,LINETHICK0,NODRAW;
DIFF:DIF,COLORRED,LINETHICK2;
DDEA:DEA,COLORYELLOW,LINETHICK2;

 

股票公式欄目導航

本類熱門

相關公式

初高中全集在线视频_9久9久女女热精品视频免费观看_人人澡人一摸人人添_yy6080理论亚洲一级理论人