大智慧強勢暴漲暴跌畫線顯示斜率值主圖指標 源碼 貼圖

2021-10-04 08:57:00來源:本站整理瀏覽:503

大智慧強勢暴漲暴跌畫線顯示斜率值主圖指標 源碼 貼圖

大智慧強勢暴漲暴跌畫線顯示斜率值主圖指標 源碼 貼圖

大智慧強勢暴漲暴跌畫線顯示斜率值主圖指標 源碼 貼圖


INPUT: 起點(5,1,9999,1),終點(1,0,9999,1);
ma(c,5);
A1:=backset(barstatus=2,起點); {原作者:奉然}
A2:=backset(barstatus=2,終點);
H1:VERTLINE(CROSS(A1 ,0.5 ) , 1),Color000fff;
H2:VERTLINE(CROSS(A2 ,0.5 ) , 1),Color00ff00;
{幅度:=(c-REF(c ,BARSLAST( CROSS(A1 ,0.5 )) ))/REF(c ,BARSLAST( CROSS(A1 ,0.5 )) )*100;}
幅度:=(REF(c ,BARSLAST( CROSS(A2 ,0.5 )) )-REF(c ,BARSLAST( CROSS(A1 ,0.5 )) ))/REF(c ,BARSLAST( CROSS(A1 ,0.5 )) )*100;{www.gpxiazai.com}
斜率:=ATAN(幅度/((起點-終點) ))*180/3.1416;
斜邊:=SQRT(POW(幅度 ,2 )+POW(起點-終點 ,2 ) );
伸長:=SUM(幅度 ,0 );
震蕩率:=伸長/斜邊;
強勢暴張:=斜率>60 ;
B1:=REF(H ,BARSLAST(CROSS(起點+(起點-終點)/2 ,0.5 ) ) );
A5:=backset(barstatus=2,起點);
A6:=backset(barstatus=2,終點);
DRAWLINE(a5,ma(c,5) ,a6 AND CROSS(A2 ,0.5 ) ,ma(c,5),1),Color000fff,linethick2;
DRAWTEXTABS(250,10,'斜率:'+NUMTOSTRN(斜率,2)),Color000fff,linethick5;
DRAWTEXT(斜率>=60 AND CROSS(A2 ,0.5 ),H*1.01 ,'強勢暴張' );
DRAWTEXT(斜率>=45 AND 斜率<60 AND CROSS(A2 ,0.5 ),H*1.01 ,'強勢大漲' );
DRAWTEXT(斜率<=-40 AND CROSS(A2 ,0.5 ),H*1.01 ,'弱勢暴跌' );
DRAWTEXT(斜率<=-20 AND 斜率>-40 AND CROSS(A2 ,0.5 ),H*1.01 ,'弱勢大跌' );

 

股票公式欄目導航

本類熱門

相關公式

初高中全集在线视频_9久9久女女热精品视频免费观看_人人澡人一摸人人添_yy6080理论亚洲一级理论人