通達信超級MACD+轉9+背離+紅綠柱體變色+金叉死叉提示副圖指標 源碼 貼圖

2022-03-01 09:27:00來源:本站整理瀏覽:2306

通達信超級MACD+轉9+背離+紅綠柱體變色+金叉死叉提示副圖指標 源碼 貼圖

通達信超級MACD+轉9+背離+紅綠柱體變色+金叉死叉提示副圖指標 源碼 貼圖

通達信超級MACD+轉9+背離+紅綠柱體變色+金叉死叉提示副圖指標 源碼 貼圖


DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:=2*(DIF1-DEA1),STICK;
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,0),COLORF00FF0;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORCYAN;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
DIFF:DIF1,COLOR33FF33;
DEA:DEA1,COLORYELLOW;
MACD:MACD1,NODRAW,COLORMAGENTA;
強:IF(DIF1>=DEA1,DIF1,DRAWNULL),COLORRED,LINETHICK2;
低位金叉:= CROSS(DIFF,DEA) AND DIFF<(-0.1);
STICKLINE(低位金叉,0,-0.3,1,0),COLOR00FFFF;
DRAWTEXT(低位金叉,-0.3,' 低位金叉'),COLOR00FFFF;
JCCOUNT:= COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:= CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,-0.15,1,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*1.04,1),COLOR0000FF;
DRAWTEXT(二次金叉,-0.15,' 二次金叉'),COLORFF00FF;
A1:= BARSLAST(REF(CROSS(DIFF,DEA),1));
底背離:= REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背離,0,0.15,1,0),COLOR00FF00;
DRAWLINE(A1=0,DEA,底背離,DEA,0),LINETHICK3,COLORWHITE;
DRAWTEXT(底背離,0.15,' 底背離'),COLOR00FF00;
A2:= BARSLAST(REF(CROSS(DEA,DIFF),1));
頂背離:= REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,頂背離,DEA,0),LINETHICK3,COLORBLUE;
AA:=C>REF(C,4);
NT:=BARSLASTCOUNT(AA);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(AY>0,MACD*1.02,VAR2STR(AY,0)),COLORLIRED;
DRAWTEXT(NT=9,MACD*1.02,'9'),COLORGREEN;
B1:=C;{WWW.GPXIAZAI.COM}
NT0:=BARSLASTCOUNT(B1);
TJ21:=NT0=9 ;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
DRAWTEXT(AY1>0,MACD*0.98,VAR2STR(AY1,0)),COLORGREEN;
DRAWTEXT(NT0=9,MACD*0.98,'9'),COLORRED;
DRAWICON(CROSS(DEA1,DIF1),DEA1,2);

 

股票公式欄目導航

本類熱門

相關公式

初高中全集在线视频_9久9久女女热精品视频免费观看_人人澡人一摸人人添_yy6080理论亚洲一级理论人